Skip to main content

Common Issues - Audio

This page is dedicated to common issues surrounding audio. If you are experiencing an issue that does not relate to audio consider looking at one of the other pages in this section, which are also listed here.

Make sure to Update Playable!
A lot of times issues can be fixed by simply updating your plugin to the latest version, please make sure to check you are on the latest release version before looking further into this section. More info on how to do this here

Audio does not play upon the playable loading#

This is because ad networks have an overarching policy to not play audio from an ad until the user has made at least one interaction.

Due to this is isn't a way to play audio upon the playable loading.

Audio Continues playing if you set the app to background or lock device#

This is likely happening due to the 'Loop' toggle on AudioSource being turned on.

Possible solution:

  • Hook into Luna Lifecycle events for OnPause and OnResume. Also be sure to turn off the 'Loop' option and stop the audio manually via code, and then have it resume when needed.

    images-medium

Audio cuts out when calling Play() on an already playing audio source#

Possible solution:

  • Check if the AudioSource is already playing, and only call Play() if false.

Audio plays in all builds except for ironSource; no audio on Android and intermittently on iOS#

Possible solution:

  • Set the ironSource API to Legacy instead of Nucleo.

    images-medium